Hyundai Sonata Forum

Hyundai Sonata Forum (https://www.sonataforums.com/forum/hyundai-sonata.html)
-   Hyundai Sonata Appearance and Body (https://www.sonataforums.com/forum/hyundai-sonata-appearance-body/)
-   -   LED taillights (https://www.sonataforums.com/forum/hyundai-sonata-appearance-body/2256349-led-taillights.html)

KenIliv82 03-19-2019 09:20 PM

LED taillights
 
2 Attachment(s)
Somebody help my taillights are dim on the outer parts sometimes the right outer doesn’t come on at all but when you hit the brake it gets bright like it should what could be wrong

BrightonB 03-23-2019 10:45 AM

I see from the license plate and Fred Beans sticker that we are both from the same area of Pennsylvania.

I have a 2018 Sonata Limited with the Tech Package. From your pictures it appears you have a 2014 Limited with the Tech Package.

I have no experience with diagnosing LED issues so I can only offer what I learned from the factory service manual. The forum site says I need more posts before I can include website links so Google "hsguide" to find the factory service manual. By the way hsguide incorrectly states that the service manual is for 2011-2019 6th generation Sonatas; code = YFA. 2015 introduced the 7th generation Sonata; code = LFA.

I was unable to obtain the schematics from the factory service manual for the LED tail lights. Per Body Electrical System / Lighting System / Specifications, the manual does not list the LED tail lights nor does the owners manual. As a result I can only offer some general help.

Starting from the back of the car going forwards, the issue is either with the tail light unit, corrosion in the connectors between the tail light and the engine compartment fuse block, frayed wiring and/or a bad engine compartment fuse block due to a failed Intelligent Power Switch (IPS). I do not think the issue is with the Body Control Module (BCM).

First a word of caution. Today's automotive electrical systems are very unforgiving of inexperienced back yard mechanics. Even jump starting a car can cause electrical issues.

I do not know your level of expertise. Start with removing and reattaching the wiring connector at the tail light. The owners manual contains the instructions on how to access that area.

If the issue continues and you are comfortable with working in the engine compartment, then in the engine compartment fuse box pull out the 'Multi Fuse' (which includes B+4) and the fuse for B+2. The instructions are in the owners manual. Look for any corrosion. If there's no corrosion then put the fuses back in. If there is corrosion then you may have found the culprit. I'm targeting these two fuses based on the fuse box schematic in Body Electrical System / Fuses And Relays / Relay Box (Engine Compartment)/ Schematic Diagrams. Midway down on the left side of the schematic there is a listing for 'Tail Ext LH', 'Tail int' and 'Tail Ext RH', respectively using B+2 (IPS7), B+4 (IPS8) and B+2[?] (IPS6).

If the issue continues then take the car to a reputable repair shop for further diagnosis. At least you'll be more knowledgeable.

Good luck and watch out for the bumper crop of PA potholes!

karkrazy13 10-11-2019 04:07 PM

1 Attachment(s)
I just installed the Vland smoked tails and I have LED's for brake/tail, turn signals and reverse lights. I love the way they look! :)


All times are GMT -4. The time now is 08:29 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome