Sonata Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All :),

So recently purchased my 2006 Sonata V4 for a very resonable price, replaced engine, which I knew would be an issue given that I had got the vehicle for such an amazing deal, car has 114,000 miles on it. I moved from Virginia, where they don't do emissions to atlanta, where they do. After attempting to get my emission done, the tech stated that my car is not reading with there emission machine. I've take it to multiple shops and the all said the same thing. I noticed that sometimes my left signal blinks fast, my car won't start at times (as if its waiting for some signal), my back doors won't unlock all the time (via the switch), and when I power the car off everything does not cut off at once all the time, its like the radio, then a couple of seconds later the inside lights do (weird, huh)
. I do not now nor have I ever had my check engine light to come on, even after the new engine was put in.

I have taken my car to Hyundai for a diagnosis, which they said that they are not sure what the definite problem is, also stated that they would have to start with replacing the fusebox, but that may not be the answer. That itself was $800+, which I do not have for maybe's. The car runs awesome, when it starts. I also notice on some colder days it will not start either.

I took my car to another electrical shop and they stated that there was some kind of wire missing in my harness, but stated that I should go to the dealership, for a second opinion. As we all know the dealership is quite pricey, and they never seen to tell you if its just something simple. They'd rather toy you around, and break your pockets. But I guess that business, huh!


I need of help/expertise, and or advice, PLEASE!!!
 
1 - 1 of 1 Posts
Top