Sonata Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2015 Sonata Sport, 89k miles.
Started the car this morning and the ABS and the Trac light stayed on. Was like that until early afternoon. Made a stop at the post office and when I came back out to the car and started it, the lights went out. Drove home and turned the car off and then turned it back on and the lights went out. Went for a drive a little bit ago and the lights were out. After about 5 minutes, they came back on. Car is braking and handling fine. Nothing out of the ordinary has happened with the car. Could there be a short or an issue with a fuse or a dirty wheel sensor? I’d like to be able to check some things before taking it to a mechanic. Read where a lot of people have had this issue and have had wheel sensors replaced and modules replaced and it doesn’t fix the issue.
 

·
Registered
2005 Sonata
Joined
·
2 Posts
If your TRACK&ASS lights came on they probably stored a code many auto supply stores will lend you a OBDII scanner or your favourite mechanic might do it. That might give you a place to start.
Regards
Wonbill
 

·
Registered
Joined
·
2 Posts
My 15 SE had a similar issue, no Speedo, ABS, Traction control and Parking Brake light on. Drove it like that for a day or 3 with no drivability issues then TPMS light came on. Tried to scan for codes, came up with nothing. Instead of shotgunning parts with HIGH labor value, I took it to my local dealer. Bad TPMS module. Replaced ... All other lights remained. More Diag... ABS module. Total for all ~$2600... 😭😭
Good luck with yours...
 

·
Registered
Joined
·
3 Posts
hi this is a little random but similar long story short I thought my brakes system was bad but I turns out I just needed rear brake pads 🤦🏽‍♀️ so again long story short before I knew my brake pads rear were bad a mechanic unplugged my ABS because I told him to so when he unplugged it my ABS and traction control light came on and my steering wheel got very very loose I later change the brakes and the car is breaking perfectly however the ABS and traction lights are still on and the steering wheel is still very loose ever since he unplugged it and plugged it back in what can I do to fix this I feel like he damage something or maybe Damaged a speed sensor while unplugging it? I know it’s an easy fix because my ABS light was never on and it was only since he unplugged it I need help I can’t even drive the car because the steering wheel is so loose thank you so much
 
1 - 4 of 4 Posts
Top