Sonata Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all. I have a strange set of problems, and while I have searched and searched this site I have yet to see anything quite like this. I have a 2006 Sonata, V6 with 126K miles.

A little background: I changed my brake pads a couple months ago. Nothing out of the ordinary for me, I've changed my fair share of brakes over the years with no incident. Well, within a day of the replacement my ABS and ESC OFF lights began lighting after driving for a bit. Sometimes they would stay on, most times they would shut off after a bit. I removed both tires and inspected the brake and hub assembly, but didn't see anything out of the ordinary. No noise, no wobble, nothing. Well, about a week ago I was driving down the road when out of nowhere my dash lit up like a Christmas tree. Brake, check engine, airbag, ABS, and ESC OFF lights all came on, and my drivers side headlight immediately went out. I also noticed some slight hesitation from the motor. Once I began braking to stop for a light, the warning lights began shutting off one by one, except for the check engine light.

I replaced the headlight bulb, and within a couple hours the dash did its light show and the new bulb burned out. I also noticed this time that when it is having these issues, the speedometer and tach both stopped working, and I began hearing static through my speakers as well. At one point, the speakers actually shut off completely, even though the head unit was still fully powered and functioning.

I've tried cleaning the positive post and clamp, inspecting the wiring coming from the battery, checking all the fuses and relays, and even pulled the stereo to check for exposed wires. No luck.

I do have an aftermarket tow package, and I saw somewhere that the wiring can possibly go bad after a while and cause electrical issues, could this be it? Or should I shell out the cash and replace the positive cable?
 

·
Registered
Joined
·
3 Posts
do you know if it's the original battery? i had a grand cherokee that did the exact same thing. it would run, but had strange electrical issues. i replaced the battery, and it was the fix.
 
1 - 2 of 2 Posts
Top